Fingerprint GUI

A place to discuss issues of the Fingerprint GUI.

You can subscribe to this discussion group using an RSS feed reader.

SD Card and USB Stick not recognised as removable

Seen a few posts on 'net about storage devices not being recognised as removable when saving password to them. I'm getting the same on Mint 18.3 Cinnamon 64, 4.13.0-32-generic - Thinkpad T420 - tried with 'normal' usb stick and SDHC card in the onboard card reader

path to SD card doesnt have anything fancy in it:
mtab for SD Card looks OK:
/dev/mmcblk0p1 /media/john/key fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0

any way to get the card to be recognised as removable?

Permalink John Dongworth 
February 5th, 2018 12:17pm
Just tried same SD Card in Lenovo X201 and it worked, so looks like something specific to the hardware in T420.

Any ideas where to look further..?

Permalink John Dongworth 
February 8th, 2018 12:54pm
Not sure if some people would consider this a bug/flaw in the software, but is possible to circumnavigate the non-removable/removable media issue.

From Documentation:

Looking at the docs for the software there are two parts to it, both xml:

This login password information is split into 2 different locations:

A file “<username>@<machinename>.xml” in a subdirectory “.fingerprints” on the chosen removable media, containing the encrypted password;

A file “config.xml” in the directory “/var/lib/fingerprint-gui/<username>” containing the path to the “<username>@<machinename>.xml” file, the UUID of the chosen partition on removable media and the key for decrypting the password.

So, by using a USB stick to save the password xml, you can then copy that to the SD Card and modify the path/UUID to SD Card to the file in var/lib/fingerprint-gui/<username> works!

February 27th, 2018 3:16pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics